anastasia8879
08.01.2023 21:18

Другу необходимо с массивами на QBasic. Да, понимаю, язык программирования старый, но это такое учебное заведение хреновое.
"
1. Составить программу и использовать ее для заполнения массива вычисления квадратных корней для С = 10 до 100 с шагом 10
2. Составить программу и использовать ее для заполнения массива из 10 элементов по формуле Z = 12*А + 4,2* А ^ 2 , А изменяется от 10 до 20. Посчитать сумму отрицательных элементов.
3. Элементы массива вычисляются по формуле а (х, у) = 2х - у. Написать программу которая,
- выводит на экран значение элементов массива А (2,2).
- подсчитать количество отрицательных элементов, равных нулю. Результата вывести на дисплей.
- подсчитать сумму положительных элементов
- выводит на экран номера всех элементов, значения которых равны нулю
"

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Fits97
09.10.2020 16:45
Параграф называется  "Понятие как форма мышления "
   В понятии отражается совокупность существенных признаков отдельного объекта или класса однородных объектов .
  Анализ, синтез , сравнение , абстрагирование и обобщение являются основными логическими приемами формирования понятий 
   Определение понятие - это перечисление всех существенных признаков объекта (класса однородных объектов ) в связном предложении . Каждый из признаков , входящих в определение , должен быть необходимым , а все вместе - достаточны для установления данного понятия 
0,0(0 оценок)
Ответ:
linanstyoxvdtf
23.01.2022 23:15

Program zadacha1;
uses crt;
const N=5;  //размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Прямой вывод');
For i:=1 to n do
writeln(m[i]);
Writeln('Обратный вывод');
For i:=1 to n do
writeln(m[n+1-i]);
End.

 

Program zadacha2;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if i mod 2 = 0 then writeln(m[i]);
End.

 

Program zadacha3;
uses crt;
const N=5; // размер массива
var m:array[1..n] of integer;
i:integer;
Begin
Writeln('Исходный массив');
For i:= 1 to n do
//readln(m[i]); //для ручного ввода оставьте эту строку
begin //    для
m[i]:=random(101)-50; // случайного
Writeln(m[i]); //  эти
end; //
Writeln('Вывод');
For i:=1 to n do
if (n+1-i) mod 2 <> 0 then writeln(m[n+1-i]);
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота