Лёха12339
18.09.2022 00:05

Составить программу, которая из трёх чисел возводит в квадрат положительные, а отрицательные оставляет без изменений.
Везде нахожу только решение в Паскале, но мне нужно конкретно в VBA Excel.
Буду очень благодарен.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anechka1234567892
23.12.2021 20:44

#include <iostream>

#include <string>

using namespace std;

string dectobin(int num) // функция для перевода

{

string result; // строка для результата

for (; num!=0; num>>=1) // цикл со сдвигом вправо на 1 бит (работает быстрее чем деление на 2,

//но также делит)

result.insert(0, num&1 ? "1" : "0"); // вставка цифры в начало строки (1 если последний бит 1, 0 если 0)

return result; // возврат результата

}

int main(int argc, char *argv[])

{

// тут думаю понятно, ввод данных и вызов функции

int num;

cout<<"Enter number: ";

cin>>num;

cout<<dectobin(num);

return 0;

}

0,0(0 оценок)
Ответ:
Собака2609
23.12.2021 20:44
#include <iostream>
#include <iomanip>
#include <cstdlib>

using namespace std;

int main() {

  bool priz;
  int n;
  cout<< "n = ";  cin>>n;
  int *a = new int[n];
  srand(time(NULL));
  for (int i=0;i<n;i++) {
     a[i]=rand()%101-50;
     cout<<a[i]<<" ";
     if (a[i]<0) a[i] = - a[i];
  }
  cout<<endl;
//  сортировка массива
   while (priz)   
   {
      priz=false;
      for (int i=1; i<n; i++)
      if (a[i]<a[i-1]) 
         {  swap(a[i],a[i-1]);  priz=true;  }
   }
// вывод массива
   cout<<"new array"<<endl; 
   for (int i=0; i<n; i++)
      cout<<a[i]<<" ";
   cout<<endl;
   system("pause");
   return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота