ЮлияСалт
22.03.2020 10:36

напишите программу на языке c# для ввода с клавиатуры двух чисел в 16-ричном формате и вывода на экран их суммы в двоичном формате.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Noltee
16.08.2020 04:15

Что такое вирусы и антивирусы.

Компьютерный вирус (КВ) – это программа создавать свои копии (не обязательно полностью совпадающие с оригиналом), внедрять их в различные объекты или ресурсы компьютерных систем, сетей и производить определенные действия без ведома пользователя. Компьютерный вирус (КВ) – это программа создавать свои копии (не обязательно полностью совпадающие с оригиналом), внедрять их в различные объекты или ресурсы компьютерных систем, сетей и производить определенные действия без ведома пользователя.

Антивирус – это программа для защиты компьютера или мобильного устройства от вредоносных программ. Термин «вредоносные программы» включает в себя все возможные виды опасных программ, таких, как вирусы, черви, трояны и вирусы- шпионы.

Подробнее о вирусах.

Различные вирусы выполняют различные действия:

Выводят на экран мешающие текстовые сообщения (поздравления, политические лозунги, фразы с претензией на юмор и т.д.); Создают звуковые эффекты (гимн, гамма, популярная мелодия); Создают видео эффекты (переворачивают или сдвигают экран, имитируют землетрясение, вызывают опадание букв в тексте, выводят картинки и т.д.); Замедляют работу ЭВМ, постепенно уменьшают объем свободной оперативной памяти; Увеличивают износ оборудования (например, головок дисководов); Вызывают отказ отдельных устройств, зависание или перезагрузку компьютера и крах работы всей ЭВМ; Уничтожают FAT, форматируют жесткий диск, стирают BIOS, уничтожают или изменяют данные, стирают антивирусные программы; Осуществляют научный, технический, промышленный и финансовый шпионаж; Выводят из строя системы защиты информации и т.д.

Симптомы вирусного заражения ЭВМ:

Замедление работы некоторых программ Увеличение размеров файлов (особенно выполняемых) Появление не существовавших ранее «странных» файлов Уменьшение объема доступной оперативной памяти (по сравнению с обычным режимом работы) Внезапно возникающие разнообразные видео и звуковые эффекты Появление сбоев в работе ОС (в т.ч. зависание) Запись информации на диски в моменты времени, когда этого не должно происходить Прекращение работы или неправильная работа ранее нормально функционировавших программ.

Существует большое число различных классификаций вирусов:

По среде обитания:

Сетевые – распространяются по сетям (Melissa). Файловые – инфицируют исполняемые файлы с расширениями .exe, .com. Также к этому классу относятся макровирусы, которые заражают неисполняемые файлы (например, в MS WORD или в MS EXCEL). Загрузочные – внедряются в загрузочный сектор диска (Boot-сектор) или в сектор, содержащий программу загрузки системного диска (Master Boot Record - MBR). Некоторые вирусы записывают свое тело в свободные сектора диска, помечая их в FAT как «плохие». Файлово-загрузочные заражать и загрузочные секторы и файлы.
0,0(0 оценок)
Ответ:
skssjsub111
30.12.2020 00:15
Вот:

uses Crt; var A, B, C; integer; begin ClrScr;    while (A > -10) and (A < 10) do    while (B > -10) and (B < 10) do     begin write(' Ввести два целых числа: ');    readln(A, B);     C:= A * B; writeln(' Произведение равно: ' ,C); end; writeln(' Программа завершена.');    readln end.

На выходе:

uses Crt; var A, B, C; integer; begin ClrScr;    while (A > -10) and (A < 10) do    while (B > -10) and (B < 10) do     begin write(' Ввести два целых числа: ');    readln(A, B);     C:= A * B; writeln(' Произведение равно: ' ,C); end; writeln(' Программа завершена.');    readln end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота