Adelyasweet246
18.01.2022 06:23

Суммирование и нахождение количества элементов в массиве язык C++ 1) Создать случайный массив Z из 10 чисел промежутка [-20; 25].

Найти в нём количество элементов кратных 5 и заменить им пятый по счету элемент массива. Вывести на экран исходный массив, найденное количество и массив с заменой

2) Создать случайный массив K из 15 чисел промежутка [-10; 25].
Найдите максимальный и минимальный из числа четных элемент. Вывести на экран исходный массив, а также максимальный и минимальный элементы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shaluni2005
28.12.2021 14:00

Объяснение:

1)

#include <iostream>

using namespace std;

int main()

{

  int Z[10];

  int b=0;

  for(int i=0;i<10;i++)

     Z[i]=rand()%46-20;

 

  cout<<"\nElements of the array::"<<endl;

 

  for(int i=0;i<10;i++)

  {

     cout<<i+1<<" = "<<Z[i]<<endl;

  }

 

  for(int i=0;i<10;i++)

  {

      if (Z[i]%5==0)

      {

       b++;

       Z[i]=Z[4];

      }

     cout<<i+1<<" = "<<Z[i]<<endl;

  }

  return 0;

}

2)

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

  srand(time(0));

  int K[15];

  int min=0;

  int max=0;

  for(int i=0;i<15;i++)

     K[i]=rand()%36-10;

 

  cout<<"\nElements of the array::"<<endl;

 

  for(int i=0;i<15;i++)

  {

     if (K[i]%2==0)

     {

       if (min > K[i]) {min=K[i];}

       if (max < K[i]) {max=K[i];}

     }

     cout<<i+1<<" = "<<K[i]<<endl;

  }

 

  cout<<"Min = "<<min<<endl;

  cout<<"Max = "<<max<<endl;

  return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота