Шуранька
09.06.2021 18:20

Задание на PascalABC ,С клавиатуры вводится строка с грамматическими ошибками.Составьте программу,которая позволяет провепить правописание. Выведите на экран количество допущенных ошибок и исправленную строку. Правописание корней "рос"- "Раст","ращ": в безударном положении буква(а) пишется только перед "ст","щ", в остальных случаях "о"
.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shikunovnikitkp00sz1
17.02.2020 05:01
//Блок-схема во вложении
//Pascal ABC.NET 3.1 сборка 1219

uses
 system;

Var
 d1,d2:datetime;
 a:integer;
begin
writeln('1 дата:');
write('День:');readln(a);d1:=d1.AddDays(a);
write('Месяц:');readln(a);d1:=d1.AddMonths(a);
write('Год:');readln(a);d1:=d1.AddYears(a);
writeln('2 дата:');
write('День:');readln(a);d2:=d2.AddDays(a);
write('Месяц:');readln(a);d2:=d2.AddMonths(a);
write('Год:');readln(a);d2:=d2.AddYears(a);
writeln('Res:',abs((d2-d1).Days));
end.

Пример ввода:
1 дата:
День:1
Месяц:1
Год:1998
2 дата:
День:2
Месяц:1
Год:1999
Пример вывода:
Res:366
Составьте алгоритм определения числа дней между двумя датами и нарисуйте блок-схему. , кто разбирает
0,0(0 оценок)
Ответ:
soykaksyu
27.04.2022 05:19
#include <cstdlib>#include <iostream>#include <iomanip>#include <cmath>
using namespace std;
int main(){    setlocale(0, "");    double x, y, a, b, xk, xn, dx;    a = 1.4;    b = 2.5;    cout << "Ââåäèòå xn,xk, dx = " << endl;    cin >> xn; cin >> xk; cin >> dx;    x = xn;    cout << "Tabl" << endl;    cout << "+-----------+" << endl;    cout << "¦ x ¦ y ¦" << endl;    while (x <= xk)          {             y = (log10(a*x*x+b))/(a*x+1);             cout << "+-----+-----¦" << endl;             cout.setf(ios::fixed);             cout.precision(3);             cout << "¦" << x << "¦"<< y << "¦" << endl;             x = x + dx;          }    cout << "+-----------+";    system("pause");}
Переделать программу паскаль в си program lab3; var x,y,a,b,xk,xn, dx: real; begin a: =1.4; b: =2.5;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота