nastya09042
07.01.2023 14:08

Дан массив размерностью 4х6. Написать программу вычисления разности между максимальным и минимальным элементами массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MrZick33446
21.05.2023 09:59
На одну чашу весов поместим 2 монеты, на другую – монету и гирю. Если весы уравновесятся, то фальшивая монета та, что осталась. За второе взвешивание определим, легче она или тяжелее любой из настоящих монет (или гири). Если же весы не уравновесятся, то наверняка можно утверждать, что настоящей является отложенная монета. Допустим, перевесила чаша, на которой находятся две монеты. Сравним эти монеты при втором взвешивании. Если весы уравновесятся, то фальшивая монета легче, и она находится рядом с гирей. Иначе фальшивой окажется более тяжелая из двух сравниваемых монет.
0,0(0 оценок)
Ответ:
dorof077
20.06.2021 01:17
//PascalABC.NET 3.2 сборка 1318

Const
  n=7;
  Var
   ma:array[1..n,1..n] of integer;
  countn,countp,i,j:integer;
  sr:real;
begin
for i:=1 to n do
  for j:=1 to n do
    begin
      readln(ma[i][j]);
      if ma[i][j]>0 then inc(countp) else
        if ma[i][j]<0 then inc(countn);
    end;
for i:=1 to n do
  begin
    for j:=1 to n do
      write(ma[i][j]:4);
    writeln;
  end;
writeln('Count of positive=',countp,', count of negative=',countn);
 for j:=1 to n do
  begin
  sr:=0;
    for i:=1 to n do
    sr+=ma[i][j];
  writeln(j,' ',sr/n);
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота