Oneheest
07.04.2021 04:47

Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере: Случайное число 83

В восьмеричной системе 123
Язык python

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Niks78492986
18.11.2020 09:41

import random

def to8(x):

       new=''

       while x>0:

           new=str(x%8)+new

           x //= 8

       return(new)

a=random.randint(64,511)

print('Случайное число',a)

print('В восьмеричной системе',to8(a))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота