gbafujhobr
25.09.2021 03:36

Написать программу вычисление функции: сначала вычисление левой части неравенства, потом правой с точностью е 4 номер


Написать программу вычисление функции: сначала вычисление левой части неравенства, потом правой с то

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
EkaterinaMironovaa
03.11.2020 07:02
1)Алгоритм шифрует блок 64 бита. На выходе получается блок 64 бита.
То что данные зашифрованы не видно. И не должно быть видно. Другое дело, что часто бывает видно, что данные НЕ зашифрованы, когда они символьные, например.
Классическая книга: Брюс Шнайер. Прикладная криптография. Там этот алгоритм описан и приведена его реализация на языке си
2)Четыре класса должны покрасить забор вокруг школы. Классы Б.В.Г могут выполнить эту работу за 3часа. Классы А, В, Г могут выполнить эту работу за 2часа. Если же будут работать классы А и Б, то работа будет выполнена за 5часов. За какое время могут покрасить забор все четыре класса?  Решение:       p (производительность)        t (время)     А (работа)  Б + В + Г          р(б) + р(в) + р(г) = 1/3           3ч.               1  А + В + Г          р(а) + р(в) + р(г) = 1/2           2ч.               1  А + Б                 р(а) + р(б)  = 1/5                     5ч.              1 А + Б + В + Г                                                     ?ч.               1   Прибавим все р, получим:  2р(а) + 2р(б) + 2р(в) + 2р(г)  =    2(р(а) + р(б) + р(в) + р(г)) =    (р(а) + р(б) + р(в) + р(г) =       Тогда время t  =                                  ответ:                        
   
0,0(0 оценок)
Ответ:
Uses crt;
const zn=[' ',':',',','!','?','-',';',')'];
var s,s1,s2:string;
i,k:byte;
begin
clrscr;
writeln('Введите строку, содержащую 2 одинаковых слова:');
readln(s);
s:=s+' ';
for i:=1 to length(s) do
if s[i] in zn then s[i]:=' ';
while pos(' ',s)>0 do
delete(s,pos(' ',s),1);
if s[1]=' ' then delete(s,1,1);
k:=0;
while pos(' ',s)>0 do
begin
s1:=copy(s,1,pos(' ',s)-1);
for i:=pos(' ',s)+1 to length(s) do
if (copy(s,i,length(s1))=s1)
and(s[i-1]=' ')
and((s[i+length(s1)]=' ')
or(i+length(s1)-1=length(s))) then
begin
k:=1;
s2:=s1;
write('Одинаковые слова ',s2);
readln;
exit;
end;
delete(s,1,pos(' ',s));
end;
if k=0 then write('Нет двух одинаковых слов');
readln
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота