azaliyazaynulinnf
20.07.2020 09:49

напишите на каком языке программировали: B. Укладка плитки
Ограничение времени 1 секунда
Ограничение памяти 64.0 Мб
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Мэр нашего города хочет уложить максимум плит размером 2 × 1 клеток без деления их пополам на площади размером K × N клеток. Требуется уложить максимум плит при условии, что:

Можно поворачивать плиты
Плиты не пересекаются
Все плиты лежат внутри площади, касание краёв допускается.
Найдите максимум плит, которые можно уложить при данных условиях.

Формат ввода
В единственной строке записано два целых числа K и N — размеры площади в клетках (1 ≤ K ≤ N ≤ 16)

Формат вывода
Выведите одно число — максимальное количество плит, которые можно уложить

Пример 1
Ввод Вывод
2 4
4
Пример 2
Ввод Вывод
3 3
4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nnika1015
06.09.2022 13:56

1) 

var X:array[12] of real;

i: integer;

 

begin

   for i:=1 to 12 do

   begin

      readln(X[i]);

      X[i]:=X[i]-23;

   end;

   for i:=1 to 12 do

      writeln(X[i])

end.

2)

var M:array[100] of integer;

i: integer;

begin

   for i:=1 to 100 do begin

      readln(M[i]);

       if(M[i] mod 2=0) then M[i]:=M[i]*M[i]

       else  M[i]=2*M[i];

   end;   

   for i:=1 to 100 do

      writeln(M[i]);

end.

3)

var price:array[20] of real;

i:integer;

minprice:real;

begin

   minprice:=10000;

   for i:=1 to 20 do

   begin

      readln(price[i]);

      if (price[i]<minprice) then minprice:=price[i];

   end;

   writeln(minprice)

end.

4) 

var M:array[100] of integer;

i, counter: integer;

begin

   readln(M[1]);

   counter:=0;

   for i:=2 to 100 do begin

      readln(M[i]);

      if ((M[i] mod 2=1) and (M[i-1] mod 2=1)) then inc(counter);

   end;

   writeln(counter)

end.

0,0(0 оценок)
Ответ:
tanyaraeva2017
29.02.2020 03:04

2)Если на столе скопилось слишком много документов и инструментов и они начали мешать работе пользователя, те окна, которые временно не нужны, можно уменьшить в размерах или же полностью свернуть. За свернутым окном сохраняются все ресурсы. Мало того, программа, окно которой свернуто, продолжает выполняться. Свернутое окно можно вновь развернуть и привести его в то состояние, которое окно имело перед свертыванием. Свернутое программное окно представлено кнопкой на панели задач, а свернутое окно документа обычно размещается в углу рабочей зоны программного окна. Свертывание окна часто называют минимизацией окна свертывания окна:

□ рекомендуемый — щелкнуть по кнопке свертывания в заголовке окна;

□ стандартный — выбрать команду Свернуть из системного меню окна;

□ дополнительный программное окно можно свернуть, щелкнув по кнопке окна на панели задач.

Кнопка свернутого окна рельефно выделена над панелью задач, а кнопка развернутого — углублена в панель. При наличии на Рабочем столе нескольких окон последний прием, в зависимости от ситуации, может привести к переключению на другое окно.5)Окно может иметь полосы прокрутки. Это говорит о том, что размер окна слишком мал, чтобы полностью отразить всѐ содержимое. Каждая полоса прокрутки имеет ползунок. Перетаскивая ползунки по полосе прокрутки, можно просмотреть в окне всю рабочую область. Небольшое смещение рабочей области выполняют щелчками на кнопках прокрутки. В одном из открытых окон выполните следующие действия: нажимайте клавишу Enter, пока не активизируется вертикальная полоса прокрутки; нажимайте клавишу пробел, пока не активизируется горизонтальная полоса прокрутки; перетащите вверх ползунок вертикальной полосы прокрутки; перетащите влево ползунок горизонтальной полосы прокрутки; вернитесь к курсору, щелкая на кнопках прокрутки.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота