жасеке
29.04.2021 20:42

Написать программу для вычисления значения логарифметических функций для данного действительного числа x. (Delphi)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ekaterinavarfo
04.05.2023 21:12

Часть программы. Решение задач

1. Найдите ошибку в программе:

program ;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

2. Найдите ошибку в программе:

program Prim 2 1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f ); p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

3. Найдите ошибку в программе:

program Prim_2_1;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

4. Найдите ошибку в программе:

program Prim_2_1;

var a,b:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

5. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

6. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

writeln('p=',p);

readln

end.

7. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

8. Следующий алгоритм в результате выполнения программы находит:

program Prim_2_3;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c;

writeln('p=',p);

readln

end

9. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p=:a+b+c+d+f;

writeln('p=',p);

readln

end.

0,0(0 оценок)
Ответ:
Adik20061
07.01.2021 04:33
Если число 49 записывается как 121, значит первый остаток от деления равен 1, то есть основанием системы счисления является число, кратное 48.

121 имеет 3 разряда, значит основание однозначно меньше 10 и больше 2. Подходят 3, 4, 6, 8.

Учитывая, что в числе 121 три разряда, значит число 48 делилось всего три раза. 
Число 8 не подойдет, т.к. 48/8=6, значит будет всего два деления.
Число 3 не подойдет, т.к. 48/3 = 16, 16/3=5 - то есть тут будет больше трёх знаков.
Число 4 не подойдет, т.к. 48/4=12, а 12 делится на 4 без остатка, но, судя по числу, во втором делении остаток должен быть равен 2.
Остаётся число 6. Проверим

49/6=8 |1
8/6 = 1 |2
1/6=0 |1

121(6)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота