Svet97
10.01.2023 00:00

Есть массив (int arr[10] = {5,4,6,17,2,3,16,9,8,1}; ). нужно написать программу, которая меняет все нечетные числа на 1, а четные – на 10. вывести элементы массива в консоль;

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Снежка555
09.10.2020 11:36

#include <iostream>  //подключаем библиотеки

#include <fstream>  //подключаем библиотеки

using namespace std; //пространство имён

int main() {

 

setlocale(LC_ALL, "Russian"); //русский

 

int arr[10] = {5,4,6,17,2,3,16,9,8,1};

 

for(int i = 0; i < 10; i++) //сортируем масссив

{

 if (arr[i] % 2 == 0)  //все четные

 {

  arr[i] = 1;    //меняем значение

  cout << arr[i] << " ";  //выводим

 }else    //все нечетные

 {

  arr[i] = 10;    //меняем значение

  cout << arr[i] << " ";  //выводим

 }

}

 

return 0; //возращаем ничего

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота