nazipovadk
06.01.2023 12:22

написать программу . Шашку — в дамки (Сириус, С++) На шахматной доске (8×8) стоит одна белая шашка. Сколькими она может пройти в дамки?

(Белая шашка ходит по диагонали. на одну клетку вверх-вправо или вверх-влево. Шашка проходит в дамки, если попадает на верхнюю горизонталь.)

Входные данные

Вводятся два числа от 1 до 8: номер номер столбца (считая слева) и строки (считая снизу), где изначально стоит шашка.

Выходные данные

Вывести одно число — количество путей в дамки.
Ввод - вывод:
3 7 - 2
1 8 - 1
3 6 - 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
OLZHAS1808
07.02.2023 18:09
Const
   K = 3;
   N = 4;
Var
   A:array[1..K,1..N] of integer;
   Max,Min,i,j:integer;
Begin
For i:= 1 to K do
    Begin
    For j:= 1 to N do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn
    End;
Max:=A[K,N];
Min:=A[K,N];
For i:= 1 to K do
    For j:= 1 to N do
        Begin
        if Max<A[i,j] then Max:=A[i,j];
        if Min>A[i,j] then Min:=A[i,j]
        End;
WriteLn('Min = ',Min);
WriteLn('Max = ',Max);
End.

Пример:

 -3  -2   5  -8
  2  -3   7   5
-10  -2   7   4
Min = -10
Max = 7
0,0(0 оценок)
Ответ:
maksi71
24.01.2023 18:03

Для стека:

const

 MAX_SIZE = 100;

var

 size, n: integer;

 stack: array[1..MAX_SIZE] of integer;

procedure push(a: integer);

begin

 inc(size);

 stack[size] := a;

end;

procedure view;

var

 i: integer;

begin

 for i := 1 to size do

   write(stack[i], ' ');

 writeln;

end;

Для очереди:

const

 MAX_SIZE = 100;

var

 head, tail: integer;

 queue: array[1..MAX_SIZE] of integer;

procedure push(a: integer);

begin

 queue[tail] := a;

 inc(tail);

end;

procedure view;

var

 i: integer;

begin

 for i := head to tail - 1 do

   write(queue[i], ' ');

 writeln;

end;

Объяснение:

Можно лучший , и учи C++

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота