Даны три натуральных числа. напишите программу определяющие существукт ли треугольник с такими длинами сторон.если такой треугольник существует то определите его тип(равносторонний, равнобедренный,разносторонний)
Program u4i_div_and_mod; var a,b,c,z,x,v:integer; begin readln(a,b,c); if((a + b)> c) and ((a + c )> b) and ((c + b )> a) then begin writeln('Yes'); if(a = b ) and( b = c ) then writeln('Ravnostor'); if(a = b) and (b <> c) then writeln('Ravnobedr'); if(a <> b ) and ( a <> c ) and (b <> c) then writeln('Raznost'); end else writeln('NO'); readln; end. cорри за ин-яз просто кодировки разные,исправь где нужно)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку