влщчцдыо
27.02.2022 16:53

Напишите программу с функцией для перевода скорости указанной в м/с в км/ч

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
angelina20172
01.02.2023 04:17

каждый бит это один разряд то есть одна штука в переводе на русский но число может быть в слове бит от 0 до 1 если обращатся к математическому языку то есть два разных значения на русском языке бит можно выразить как да и нет или как истина и ложь или такой и сякой а на языке рисования можно взять кувалду ударить об стену и круг получившийся назвать ноликом или единичкой а чтото другое противоположным то есть если 0 назвали то это будет 1 хотя ему лишь различно выглядеть нужно а не выглядить противоположным. А вот слово разряд можно перевести как даже место в котором хранится в цифра, в разных системах счисления разная великость цифры например тут макс. 1 а там может быть и 9 и даже буквами рисуют означающие 15 например. Переводить слово разряд как место под цифру и бит как штуку это совсем вольный перевод мнение конечно будет менятся но пока что он удачен. Где то в непроверенных интернетах может это были комментарии пишут что цифра это то как число рисовать, число это сколько оно значит, ну а квадратик как в таблице умножения рисуют часто или яйчейка то есть место под цифру это разряд, не знаю можно ли им верить.

конкретно в ip адресе по 3 цифры перед точкой кажись в максимуме (но это крайне не точно) в десятичном представлении например адрес маршрутизатора 192.168.0.1 это значит нужно взять такое кол-во бит в двоичной системе чтобы из них число трёхциферное могло получится а это ln(192)/ln(2) далее округлить в большую до целого = 8 бит значит по 8 бит (по восемь циферек 1 или 0 в математическом языке) нужно отсчитать перевести их в десятичную систему и поставить точку ну соответственно раз точка ставится значит хоть и пишем (рисуем) цифры всё - равно это мы излагаемся на русском языке или математическом письменном языке так как в математике чистой или в информатике в устройстве точку не поставишь. Но это из неточного предположения что выше 256 цифры (макс 255 так как 0 тоже занимает место) не понадобится в ip адресе, а так 3 штуки влезет и 999 в десятичной системе и под него больше бит надо чем 8 шт., думаю под задачу и 256 хватит вполне, сколько понадобится под 999 считать через ln(999)/ln(2) далее округ. в больш. до целого, но в ip кажись от 0 до 255 макс хоть и не точно . А одиночный 0 или 1 можно написать как 000 или 001 тогда тоже 3 цифры а значение тоже выходит если вдруг такой приём конечно понадобится. Вопрос откуда начинать справа или слева у 10001001011100110001011001101010. Нарежем срава навсякий.

10001001.01110011.00010110.01101010

переводим через калькулятор окон xp: ответ

137.115.22.106

Объяснение:

0,0(0 оценок)
Ответ:
Lenechka20
26.06.2022 09:26

См. Комментарии в строках с //. Пишу с телефона, поэтому не очень удобно комментировать.

Объяснение:

// Подключаем хедер //iostream

#include <iostream>

// Будет использоваться //пространство имен std

using namespace std;

#pragma argsused

// функция main

int main(int argc, char* argv[])

{

// объявление

// двумерного массива 4 //на 4

int massiv[4][4];

int n=4;

// цикл для ввода данных //массива

for(int i=0;i<n;i++)

for(int j=0;j<n;j++)

{

cout<<"Vvedite el-t matrix["<<i+1<<"]["<<j+1<<"] ";

cin>>massiv[i][j];

}

// цикл для вычисления

//сумм по столбцам

for(int j=0;j<n;j++)

{ int sum=0;

bool flag=true;

for(int i=0;i<n;i++)

{

sum+=massiv[i][j];

if(massiv[i][j]<0)flag=false;

}

// Если не было

//отрицательных

//элементов то выводим //сумму

if(flag==true)

{

cout<<"Summa "<<j+1<<" stolbca = "<<sum;

}

}

// в этом цикле ничего не происходит

int summin=0;

for(int k=0;k<n-1;k++)

{

int sum=0;

for(int j=n-1;j>=0;j--)

{

for (int i=0;i<n-1;i++)

{

}

}

if(summin>sum)summin=sum;

}

return 0;

}​

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота