tv7antena
18.06.2020 19:45

PYTHON, программирование, Условие
Аркаша очень любит путешествовать велосипедом на дальние расстояния. Как-то раз он решил проехать целых километров по очень красивому и полному достопримечательностей маршруту. Но вот беда — его текущая форма не позволяет пока проезжать больше километров в день. Сколько всего дней понадобится Аркаше, чтобы проехать весь маршрут?

Формат входных данных
С клавиатуры вводятся два целых числа — и
(1≤,≤30000)

Формат выходных данных
Выведите, сколько всего дней понадобится Аркаше.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lesa222
06.10.2020 13:56
Задача на динамическое программирование. Советую почитать поподробнее на эту тему в интернете. Подобные задачи для изучения: платная лестница, кузнечик, последовательность Фибоначчи.
#include <iostream>
#include <cmath>
using namespace std;
int main()  {
   int n;   
   cin >> n;   
   int height[n];   
   for(int i=0; i<n; i++)       
      cin >> height[i];    
   int energy[n];   
   for(int i=1; i<n; i++)
   energy[i] = energy[i-1] + abs(height[i]-height[i-1]);
   cout << height[n-1];
   return 0;
}
0,0(0 оценок)
Ответ:
LadyDiana17
11.04.2023 23:29
1) один символ (например буква) = 1 байт. 1 байт = 8 бит (или по другому - 8 разрядов). Некоторые символы, например иероглифы не умещаются в 1 байт потому что их много, поэтому для них используют не один байт, а больше. Если для символа нужно больше 8 бит, то прибавляют не недостающее число битов, а удваивают число байт. Поэтому буквы (символы) или 8-ми разрядные (1 байт), или 16-ти разрядные (2 байта), или 32-х разрядные (4 байта).
2) МАМА - это 4 обычных символа, или 4 байта (32 бита).
3) один байт, или 8 бит.
4) 15 байт - количество всех букв + пробелы + точка. Или 120 бит.
5) 21 байт, или 168 бит (все буквы + пробел + точка).
6) 7 букв = 7 байт.
7) 20 х 40 = 800 символов/страница. 2 страницы = 1600 символов. 1600 символов = 1600 байт, или 1600 х 8 = 12800 бит.
8) 20 байт.
9) большой латинской "ай" - "I".
10) латинская буква "N".
11) маленькая латинская "ай" - "i". Из формулы Хартли N=2^{i}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота