PYULIK12
15.07.2021 03:07

Памахите! Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 2.
Это все- больше в задаче ничего нет. Язык программирования- родной Русский.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Riiiiiii
31.01.2021 21:16
1 задача

var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.

2 задача

var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.
0,0(0 оценок)
Ответ:
Элиманго
31.01.2021 21:16
1 задача

var
X_1, Y_1, X_2, Y_2, AC, BC, AB:real;
begin
writeln('Введите значания X_1 (точки A)');
readln(X_1);
writeln('Введите значания Y_1 (точки A)');
readln(Y_1);
writeln('Введите значания X_2 (точки B)');
readln(X_2);
writeln('Введите значания Y_2 (точки B)');
readln(Y_2);
AC:=X_2-X_1;
BC:=Y_2-Y_1;
AB:=sqrt((AC*AC)+(BC*BC));
writeln('Длинна отрезка AB равна ', AB);
end.

2 задача

var
A, B, C, P, S:real;
begin
writeln('Введите сторону A');
readln(A);
writeln('Введите сторону B');
readln(B);
writeln('Введите сторону C');
readln(C);
P:=(A+B+C)/2;
S:=sqrt(P*(P-A)*(P-B)*(P-C));
if(A+B<=C) or (A+C<=B) or (B+C<=A) then
writeln('Треугольник с такими сторонами не существует')
else
writeln ('Площадь треугольника по теореме Герона равна ', S);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота