BDE555555дима
01.11.2021 03:49

Код программы и блок схемы для каждой проблемы : Проблема (1) - относится к простым типам данных.

Проблема (2) - к условной инструкции if.

Проблема (3) - к инструкции switch.

Проблемы:

1. Рассмотрим два целых числа. Напишите программу, которая присваивает логической переменной T значение True, если заданные числа равны, в противном случае значение False.
2. Рассмотрим два целых числа. Если первое число меньше модуля второго числа, то первое число уменьшается в 10 раз, в противном случае числа возводятся в квадрат.
3. Серийный номер недели считывается с клавиатуры. Напишите программу, которая отображает количество пар, которые у вас есть на сегодняшний день.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
кек903
12.12.2020 02:02

{НАПИШИТЕ ПРОГРАММУ ДЛЯ ПАСКАЛЯ:
1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В,
 состоящей из 8 элементов вещественного типа. Ввод организуйе без использования цикла
2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С
 состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ".
3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д
 состоящего из 10 элементов целого типа.
 Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса}

var
    B: array [1..10] of real;
    C: array [1..10] of integer;
    D: array [1..10] of integer;
    i:integer;

begin
    writeln('Введите 8 элементов В');
    read(b[1], b[2], b[3], b[4], b[5], b[6], b[7], b[8]);
    
    writeln('Введите 7 элементов C');
    for i := 1 to 7 do read(C[i]);
    
    for i := 1 to 10 do D[i] := i * i;
    
    writeln();
    for i := 1 to 8 do write(B[i], ' ');
    writeln();
    for i := 1 to 7 do write(C[i], ' ');
    writeln();
    for i := 1 to 10 do write(D[i], ' ');
end.

0,0(0 оценок)
Ответ:
Выберитеникмен
12.12.2020 02:02

{НАПИШИТЕ ПРОГРАММУ ДЛЯ ПАСКАЛЯ:
1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В,
 состоящей из 8 элементов вещественного типа. Ввод организуйе без использования цикла
2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С
 состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ".
3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д
 состоящего из 10 элементов целого типа.
 Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса}

var
    B: array [1..10] of real;
    C: array [1..10] of integer;
    D: array [1..10] of integer;
    i:integer;

begin
    writeln('Введите 8 элементов В');
    read(b[1], b[2], b[3], b[4], b[5], b[6], b[7], b[8]);
    
    writeln('Введите 7 элементов C');
    for i := 1 to 7 do read(C[i]);
    
    for i := 1 to 10 do D[i] := i * i;
    
    writeln();
    for i := 1 to 8 do write(B[i], ' ');
    writeln();
    for i := 1 to 7 do write(C[i], ' ');
    writeln();
    for i := 1 to 10 do write(D[i], ' ');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота