sachachura
16.05.2021 01:54

Написать программу на языке Паскаль: Определить стоимость покупки и размер сдачи. Цена товара, количество купленных килограмм и количество поданных кассиру денег вводятся с клавиатуры. Дано: M-кол-во поданных денег, С- цена товара, К- кол-во кг. Найти: S- стоимость покупки, Р-размер сдачи. Решение: S=С+К, Р=М-S *

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
polinagupalo200
11.01.2022 10:56

4 бита, это комбинация из 4-х чисел, от 1 до 0.  

Максимальное число, которое можно закодировать 4 битами это 1111 в двоичной системе, а в 10-тичной системе это число 15 (8+4+2+1).  

Итого у его может быть максимум 15 пятерок.  

Если допустить, что он получил максимум 5-ток, а это15, то тогда 160-15=145 четверок получил.  

Но, если он получил 14 оценок, это по прежнему будет 14 бит, но комбинация будет 1110.  

13 - 1101, 12 - 1100, 11 - 1011, 10 - 1010, 9 - 1001, 8 - 1000, 7 -111.  

Исходя из некоректных условий задачи, мы можем знать только то, что пятерок у ученика от 8 до 15 (8, первое число которое кодируется 4-ю битами, и 15 которое последнее).  

Задача,увы, неправильная.

Объяснение:

0,0(0 оценок)
Ответ:
MrCapuchino
11.01.2022 10:56
Var
 x,a,b,c,max,min,mid:real;
begin
 readln(x);
 a:=sin(x);
 b:=cos(x);
 if a>0 then
  begin
   c:=ln(x);
   if (a>b) and (a>c) then max:=a else
   if (b>a) and (b>c) then max:=b else max:=c;
   if (a<b) and (a<c) then min:=a else
   if (b<a) and (b<c) then min:=b else min:=c;
   if (a>min) and (a<max) then mid:=a else
    if (b>min) and (b<max) then mid:=b else mid:=c;
   writeln(min,' ',mid,' ',max);
  end
 else
  if a>b then writeln(b,' ',a) else writeln(a,' ',b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота