emmiemgrowen2356
20.03.2021 08:04

сделать программу на c# кому не сложно! В соответствии с заданным вариантом написать программу, используя
оператор цикла while() или do while()
Задание:
С клавиатуры вводится число N (int). Определить, может ли
оно быть двоичным (т. е. состоять только из 1 и 0) при цикла for.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
раминок1
11.10.2021 09:20

using System;

namespace restless

{

   class Program

   {

       static void Main(string[] args)

       {

           int N;

           bool _isBin = true;

           N = Convert.ToInt32(Console.ReadLine());

           N = Math.Abs(N);

           while (N > 0)

           {

               if (N % 10 != 0 && N % 10 != 1)

               {

                   _isBin = false;

                   break;

               }

               N /= 10;

           }

           Console.WriteLine(_isBin);

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота