
#include <iostream>
using namespace std;
int main()
{
int length, kilometer;
cout << "Введите расстояние (в метрах): ";
cin >> length;
if (length < 1000) {
cout << "0 км. " << length << " м.";
}
else {
kilometer = length / 1000;
length = length % 1000;
cout << kilometer << " км. " << length << " м.";
}
}
Объяснение:
Вариант 23. Написать программу, которая переводит расстояние, указанное в метрах, в километры и метры.