mkudryavceva10
30.01.2020 14:54

Условие: Требуется написать программу которая в исходном трехзначном числе x меняют местами цифры сотен и десятков, единицы оставляет в исходном состоянии выводит полученное число.
Формат входных данных:
Входной поток содержит целое число (100< x <999)
Формат выходных данных:
Программа должна вывести трехзначное число - результат указанной перестановки цифр в числе x.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
KrASaVa307
04.10.2021 22:00

Программа написана на языке C# (.NET Framework)

- Если число должно выдаваться пользователем:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

int o = Int32.Parse(Console.ReadLine());

if (o < 100 || o > 999)

{

Console.WriteLine("Ошибка!");

Console.ReadLine();

}

else

{

int a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

- Если число должно выдаваться с запуском программы:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

Random rnd = new Random();

int o = rnd.Next(100, 999),

a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(o);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота