lizadexx
26.03.2022 18:37

Напишите программу для расчета итоговой суммы награды игрока. Алгоритм должен отвечать следующим условиям: Бонус начисляется только если игрок получит максимум за прохождение уровня.
Если игрок получил за уровень меньше максимума, то бонус он не получает.
Размер получаемого бонуса определяется согласно нижеприведенной таблице
1 уровень - x0,5 от награды за текущий уровень
2 уровень - х1 от награды за текущий уровень
3 уровень - х1,5 от награды за текущий уровень
4 уровень - х2 от награды за текущий уровень
5 уровень - x2,5 от награды за текущий уровень
6 уровень - x3 от награды за текущий уровень
7 уровень - x3,5 от награды за текущий уровень

Напиши программу для расчета бонуса на языке программирования Python.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vlados22fhgff
04.10.2021 15:50

ответ: Вроде вот так

Объяснение:

Var a: array[1..100000] of integer; i,max,n: integer; begin readln(n); for i: = 1 to n do   read(a[i]); max: =a[1]+a[n]; for i: = 2 to n div 2 do   if max < a[i] + a[n-i] then       max: = a[i] + a[n-i]; writeln(max); end

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота