valeri0910200
07.09.2021 16:18

Напишите программу на языке С++, которая производит расчет по формуле, и выводит результат на экран. Расчет по формуле сделать с использованием операторов циклов: for и while. Оператор for используйте для вычисления сумм и произведений, оператор while - для организации основного цикла.


Напишите программу на языке С++, которая производит расчет по формуле, и выводит результат на экран.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
asia1406
25.05.2023 11:16
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var x:=ArrRandom(n,-5,25); x.Println;
  var y:=ArrRandom(n,-5,25); y.Println;
  var z:=x.Zip(y,(p,q)->p-q).ToArray; z.Println;
  var s:=z.Sum;
  var c:=s<0 ? 'отрицательный' : s=0 ? 'отсутствует' : 'положительный';
  Writeln('Сумма равна ',s,', знак суммы ',c)
end.

Пример
n= 13
2 -5 24 3 23 22 -3 6 -3 -2 9 25 8
17 9 11 8 0 -2 -2 2 25 19 16 21 -4
-15 -14 13 -5 23 24 -1 4 -28 -21 -7 4 12
Сумма равна -11, знак суммы отрицательный
0,0(0 оценок)
Ответ:
MrNazick
11.03.2020 16:41
её главный недостаток - то, что она оказалась слишком хорошей в сравнении с Access. Как результат, компания Microsoft перестала поддерживать VFP после версии 9.0, чтобы все же продвигать Access.
Прочие недостатки как раз явились уже следствием - невозможность работы с .NET, с современными средствами доступа к "большим" СУБД и т.д. Далее, отсутствуют защиты данных, данные не шифрованы, открыто лежат в файле.
А так, говорить о недостатках абстрактно - это неверно. Можно говорить о недостатках в сравнении с какой-то другой, более удачной СУБД.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота