sashka4erepashka
04.08.2021 09:08

Python! Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

Примеры
входные данные:
5
1 2 3 4 5
выходные данные:
4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
смурфик15
11.04.2023 16:38

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   // problem 1 //

   ll x;

   cin >> x;

   if(x > 0)

       x *= 5;

   else

       x -= 10;

   cout << x << "\n\n";

   // problem 1 //

   // problem 2 //

   ll a[3];

   for(ll i = 0; i < 3; i++)

       cin >> a[i];

   sort(a,a+3);

   cout << a[0] + a[1] << "\n\n";

   // problem 2 //

   // problem 3 //

   ll y;

   cin >> y;

   if(y > 0)

       y++;

   else

       y -= 2;

   cout << y << "\n\n";

   // problem 3 //

   // problem 4 //

   ll b[3];

   for(ll i = 0; i < 3; i++)

       cin >> b[i];

   sort(b,b+3);

   cout << b[2] + b[1];

   //problem 4 //

}

0,0(0 оценок)
Ответ:
frikadel1
11.04.2023 16:38
1.
алг
нач цел X
ввод X
если X>0 то 
X:=X+1
все
вывод X 
кон

2.
алг
нач цел X
ввод X
если X>0 то
X:=X+1
иначе
X:=X-2
все
вывод X 
кон

3.
алг
нач цел X
ввод X
 если X>0 то
  X:=X+1
 все
 если X<0 то
  X:=X-2
 все
 если X=0 то
  X:=10
 все
вывод X
кон

4.
алг
нач цел X,Y,Z,N
ввод X,Y,Z
N:=0
если X>0 то
N:=N+1
все
если Y>0 то
N:=N+1
все
если Z>0 то
N:=N+1
все
вывод N
кон

5.
алг
нач цел X,Y,Z,N,K
ввод X,Y,Z
N:=0
K:=0
если X>0 то
N:=N+1
иначе
K:=K+1
все
если Y>0 то
N:=N+1
иначе
K:=K+1
все
если Z>0 то
N:=N+1
иначе
K:=K+1
все
вывод N,K
кон

Самые наиболее простые варианты выбрал думаю в самый раз
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота