maximp1699
01.01.2021 03:38

Найти сумму 15-ти членоы ряда начиная со второго. Надо написать программу В ПАСКАЛЕ FREE, не трубо паскале


Найти сумму 15-ти членоы ряда начиная со второго. Надо написать программу В ПАСКАЛЕ FREE, не трубо п

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sumsckojr44
31.01.2020 22:04
На C# со скриншотами с результатом.
 Console.WriteLine("Введите А");           

int a = Convert.ToInt16(Console.ReadLine());           

Console.WriteLine("Введите Б");           

int b = Convert.ToInt16(Console.ReadLine());           

Console.WriteLine("Введите В");           

int c = Convert.ToInt16(Console.ReadLine());           
 
int x=0;           

if (a % 2 == 0 && b > 0 && c % 5 == 0)            {               
 x = a + b + c;
Console.WriteLine("---------------------------");               
 
Console.WriteLine(a + "+" + b + "+" + c + "=" + x);            }           
 
else { Console.WriteLine("---------------------------");

 Console.WriteLine("a=" + a * 2 + "; b=" + b * 2 + "; c=" + c * 2); }                           

Console.WriteLine("---------------------------");               

Console.ReadLine();
Запросить 3 числа (a,b,c) ,если первое четное ,второе больше 0 ,а третье кратно 5, то найти сумму эт
Запросить 3 числа (a,b,c) ,если первое четное ,второе больше 0 ,а третье кратно 5, то найти сумму эт
0,0(0 оценок)
Ответ:
RassiaScream
23.06.2021 14:35
Type
mas=array[,]of integer;
var
  i,n:integer;
  a:mas;
  b:array[1..4]of integer;
begin
write('Сколько точек: ');
readln(n);
setlength(a,3,n+1);
for i:=1 to n do
  begin
  write('Введите координаты точки: ');
  readln(a[1,i],a[2,i]);
  end;
for i:=1 to n do
  begin
  if a[2,i]=0 then
    begin
    if b[1]=0 then b[1]:=i else if a[1,i]<a[1,b[1]] then b[1]:=i;
    if b[2]=0 then b[2]:=i else if a[1,i]>a[1,b[2]] then b[2]:=i;
    end;
  if a[2,i]>0 then
    if b[3]=0 then b[3]:=i else if a[2,i]>a[2,b[3]] then b[3]:=i;
  if a[2,i]<0 then
    if b[4]=0 then b[4]:=i else if a[2,i]<a[2,b[4]] then b[4]:=i;
  end;
writeln('Координаты вершин четырехугольника с наибольшей площадью:');
for i:=1 to 4 do write('(',a[1,b[i]],';',a[2,b[i]],') ')
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота