лена1278
14.07.2021 23:08

С++ Дан массив a состоящий из n целых чисел. Требуется найти количество пар соседних элементов массива, оканчивающихся нулем.

Формат входных данных
На первой строке записано целое число n (0 На второй строке через пробел записаны n чисел (−1000≤ai≤1000) — элементы массива.

Формат выходных данных
Требуется вывести единственное число — количество пар соседних чисел, оканчивающихся нулем.
входные данные
6
11 79 10 830 4 3
выходные данные
1

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
agibalovaksyu
19.09.2021 22:20

#include <iostream>

using namespace std;

int main(int argc, char *argv[])

{    

   // Считываем длину массива

   int arrayLen;

   cin >> arrayLen;

   

   // Создаем массив длинной n и считываем в него элементы

   int *array = new int[arrayLen];

   for (int i=0;i<arrayLen;i++)

   {

       cin >> array[i];

   }

   

   // Счетчик пар

   int pairCounter = 0;

   for (int i=0;i<arrayLen-1;i++)

   {

       // Если остаток от деления на 10 (последняя цифра) равен нулю у текущего и

       // следующего элемента, то увеличивает счетчик

       if (array[i] % 10 == 0 && array[i+1] % 10 == 0)

       {

           pairCounter += 1;

       }

   }

   

   cout << pairCounter << endl;

   delete[] array;

   

   system("pause");

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота