кот1555
16.05.2020 03:33

На питоне. напишите программу, им в которой пользователю предлагается дополнить до 100 некоторое целое число a (а - случайное число, меньше 100).​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
лаура1446
25.09.2021 15:02

#include <iostream>

using namespace std;

class circle {

public:

   int x, y;

   double r, s;

   circle()

   {        

       x = 0;

       y = 0;

       r = 0;  

   }

   circle( int a = 0, int b = 0, double c = 0 )

   {

       set(a, b, c);        

   }

   void out()

   {

       cout << "Координаты: (" << x << ", " << y << ") Радиус: "<< r << " Площадь: " << endl;        

   }

   void set(int a, int b, double c)

   {

       x = a;

       y = b;

       r = c;

   }    

   void calculate() {

       s = r * r * 3.14159;        

   }

};

 

class sphere : public circle {

private:

   double  v;

   void calculate() {      

       s = 4 * 3.14 * r * r;  

       v = 3.14159 * pow(r, 3);

   }    

public:

   sphere();

   sphere() : circle(circle, double = 1.0);

   sphere (int = 0, int  = 0, double = 1.0) ;

 

 

 

void out()

   {

       circle::out();

       cout << ", радиус: " << r << ", длина: " << ", площадь: " << s;        

   }

};

int main(){

   setlocale(LC_ALL, "ru");

   circle a(2, 15, 4);

   a.out();

   sphere b;

 

   

   system("pause");

   return 0;

}

Объяснение: пойдёт?

0,0(0 оценок)
Ответ:
228дима228ннчнччн
28.04.2023 23:04

Это звуки, запахи, прикосновение.

Выживание популяции животных во многом базируется на обмене информационными сигналами между членами одной популяции. Целесообразное поведение живых организмов строится на основе получения информационных сигналов.

Язык хвостов у волков например.

Животные имеют нервную систему, управляющую всеми стадиями информационного процесса: восприятия, передачи, обработки и использования информации.

В отличие от растительного мира, животные могу передавать информацию друг другу.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота