antanika2000
14.02.2023 18:44

Написать программу на C. Вычислить сумму целых чисел кратных 4 в интервале от 0 до 200. Выполнить пошаговую компиляцию (трассировку) программы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MaXD1337
02.08.2020 07:02
Правило перевода целых чисел из десятичной системы счисления в любую другую. 1.     Последовательно выполнять деление данного числа и получаемых целых частных на основание новой системы счисления до тех пор, пока не получиться частное, меньше делителя. 2.     Выписать полученные остатки, являющиеся  цифрами числа в новой системе счисления, начиная с последнего остатка.
908=1110001100

Правило перевода правильных дробей из десятичной системы счисления в любую другую. 1.     Последовательно умножаем данное число и получаем дробные части произведения на основание новой системы счисления до тех пор, пока дробная часть произведения не станет равна нулю или не будет достигнута требуемая точность представления числа. 2.     Составить дробную часть числа в новой системе счисления, начиная с целой части первого произведения.
0,12=0,001

А теперь складываем получившиеся целую и дробную часть
получаем 1110001100,001

2 пример: 1001(10) = 1111101001(2)
0,67(10)=0,10101(2
получаем 1111101001,10101(2)

3 пример
450(10)=110011010(2)
0,304(10)=0,1001(2)
получаем 110011010,10101(2)

решение первого примера на фото, надеюсь поймете
Переведите десятичное число в двоичную систему: а) 908,12 б)1001,67 в) 450,304 ,инфа 8 класс))
0,0(0 оценок)
Ответ:
polinkamalinka28
12.09.2021 09:12

const n = 10; //В константе n указываем количество элементов в массиве

var a:array[1..n]of integer;

i,s,max,min:integer;

begin

write('Массив: '); //Вывод на экран слова "Массив: "

for i:= 1 to n do //Цикл с параметром для последовательной обработки массива

begin

a[i]:= random(21)-10; //Заполнение массива случайными числами из промежутка [-10,10]

if (a[i]>0){//Проверяем положительный элемент или нет} and (a[i] mod 2 = 0){//Проверяем чётный элемент или нет} then s:=s+1; //В переменной s будет считаться количество чётных положительных элементов при выполнении, указанных условий

write(a[i],'  ') //Вывод на экран массива в строку

end;

writeln; //Переход на новыю строку

if s=0 then write('Чётных положительных элементов в массиве нет') //Вывод на экран сообщения "Чётных положительных элементов в массиве нет" и завершение программы

else //Продолжении программы при нахождении хотя бы 1-го чётного положительного элемента

begin

max:=2; //Т.к. 2 минимальное чётное положительное число, то присваиваем это значение переменной max

for i:= 1 to n do //Поиск max элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]>max){//Проверяем больше текущий элемент max или нет} then max:=a[i]; //Присваиваем переменной max значение текущего элемента при выполнении, указанных условий

min:=max; //Т.к. max значение элемента массива уже найдено, то переменной min присваиваем значение переменной max

for i:= 1 to n do //Поиск min элемента

if (a[i]>0) and (a[i] mod 2 = 0) and (a[i]<min){//Проверяем меньше текущий элемент min или нет} then min:=a[i]; //Присваиваем переменной min значение текущего элемента при выполнении, указанных условий

if max=min then write ('Максимальным и минимальным чётным положительным элементом является один и тот же элемент: ',max) //Вывод на экран результатов

else

begin

writeLn('Максимальный чётный положительный элемент: ',max);//Вывод на экран результатов

write('Минимальный  чётный положительный элемент: ',min)//Вывод на экран результатов

end

end

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота