stas289
13.12.2020 05:49

Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина списка тоже должна быть случайной в диапазоне от
10 до 20. Потом программа должна найти в этом списке все элементы, меньшие
заданного пользователем значения, сформировать из них новый список и
напечатать первоначальный и полученный списки.Напишите программу на питоне

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hhggg1
26.08.2021 15:22

import random

list = []

numbers_range = random.randint(10, 20)

for i in range(numbers_range):

   numbers = random.randint(1, 100)

   i = numbers

   list.append(i)

user_number = int(input('Введите число: '))

user_list = []

for j in list:

   if j < user_number:

       user_list.append(j)

print(list)

print(user_list)

Объяснение:


Напишите программу, которая будет генерировать список случайных чисел в диапазоне от 1 до 100. Длина
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота