yarik28032001
15.06.2022 10:19

решить С++ Написать программу с функцией для распечатки в обратном
(инверсном) порядке текстовой строки, реализованной в виде символьного массива. Рассмотреть возможность использования рекурсии.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
просвятленный
08.08.2021 11:29

/*cpp-файл с комментариями к коду в закрепе*/

#include <iostream>  

using namespace std;  

void reverse(char *str);  

void main()

{

setlocale(LC_ALL, "RU");

char str[80];

cin >> str;

reverse(str);

}

void reverse(char* str) {

if (*str)

 reverse(str + 1);

else

 return;

cout << *str;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота