шиканова
22.11.2022 03:53

Написать программу, которая вводит двумерный массив 3х3 из целых чисел, выводит его на экран в виде матрицы, а затем выводит квадратный корень из каждого элемента. 8 3 5
9 3 8
9 4 3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

Free Pascal

const

 n=3;

var

 a : array [0..n-1, 0..n-1] of integer;

 i, j : integer;

begin

(* тут вводим массив поэлементно *)

 writeln('Введите массив A: ');

 for i:=0 to n-1 do

   for j:=0 to n-1 do begin

     write('a[',i,',',j,']=');

     readln(a[i,j]);

   end;

(* печатаем массив в виде матрицы*)

 for i:=0 to n-1 do begin

   for j:=0 to n-1 do

     write(a[i,j], ' ');

   writeln;

 end;

(* печатаем в виде матрицы корни из каждого соответствующего элемента*)

 for i:=0 to n-1 do begin

   for j:=0 to n-1 do

     write(sqrt(a[i,j]):2:2, ' ');

   writeln;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота