Dildabekova61
06.03.2022 14:15

Ребята , с задачей: Задача 9. Пирамидка 2

Напишите программу,

которая получает на вход количество уровней пирамиды и выводит их на экран,

Пример:

1
3 5
7 9 11
13 15 17 19
21 23 25 27 29

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
voolll
13.12.2021 18:11
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77
0,0(0 оценок)
Ответ:
28883
02.09.2022 07:13
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (x,y):=ReadReal2('Введите x и y через пробел:');
  Writeln(x**y)
end.

Примеры
Введите x и y через пробел: 2 20
1048576

Введите x и y через пробел: -2 20
1048576

Введите x и y через пробел: -2 19
-524288

Введите x и y через пробел: -0.7 19
-0.00113988951853731

Введите x и y через пробел: 3 -5
0.00411522633744856

Введите x и y через пробел: -3.5 -2.4
NaN

В последнем примере NaN - "Not a Number" (не число).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота