2839275
01.05.2020 15:15

написать программу на С++ Дано целое число N (> 1), являющееся числом Фибоначчи: N = FK Последовательность чисел Фибоначчи FK определяется следующим образом:
F1 = 1, F2 = 1, FK = FK−2 + FK−1, K = 3, 4, . . . .
Найти целое число K — порядковый номер числа Фибоначчи N

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Serebrennikova217
24.02.2023 23:50
Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write('Введите строку : ');
    readln(s);
    write('Введите слово : ');
    readln(a);
       if(pos(a, s) <> 0) then writeln('Слово "',a,'" в строке есть')
       else writeln('В строке такого слова нет');
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет
0,0(0 оценок)
Ответ:
мир276
15.01.2022 04:39
Переводим 112 и 64 в 2СС . 
112 =1110000
 64 =1000000
так как байт - это 8 бит ,следовательно в числе должно быть восемь знаков , тогда добавляем перед числами по незначащему нулю , тогда
112 = 01110000
64 = 01000000
адрес сети получается , когда мы применяем поразрядную конъюнкцию (между маской и ip адресом)
01110000
<-- маска 

01000000
мы видим в адресе сети единицу и над ней в ip адресе тоже единица , значит на этом месте в маске может быть только 1 .
Так как в маске у нас идут (СТРОГО) сначала единицы ,потом нули, тогда маска будет равна 11000000 , что в переводе в 10 -ную СС =192
ответ : 192
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота