kantuz
03.05.2020 09:33

Написать программу на Python которая напечатает все возможные комбинации слов (от A до Z) в консоль. Именно все возможные, вот прямо всё что можно написать используя только 4 символа английского алфавита

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
byrzakovskaya
17.06.2021 19:10

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               print(k + l + m + n)

насчет повторов не уверен, если будут, то:

l = []

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               l.append(k + l + m + n)

l = set(l)

for i in l:

   print(i)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота