DanilPRO20172007
16.09.2022 03:44

Составьте программу по этому. a-7, b-8program test; var a, b, c; integerbegin readen (a, b); c: =(a+b) *(b-a) write m,(c) end ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
RedZilla54
16.06.2020 07:50

program expression;

var

 x, y: real;

begin

 read(x);

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;

 write(y);

end.

Объяснение:

program expression;  // Название программы

var

 x, y: real;  // Две переменные являются вещественными (требуется для power)

begin  // Начало программы

 read(x);  // Вводим число с клавиатуры

 y := power(x, 4) - 3 * power(x, 3) + 5 * x - 6;  // Само выражение

power(число, которое нужно возвести в степень | сама степень)

power(x, 4)

x - число

4 - степень

 write(y);  // Выводим ответ

end. // Начало программы

0,0(0 оценок)
Ответ:
angelina436
09.10.2022 20:52

Объяснение:

Программы буду писать на языке Python3

Задание 1

a = int(input("Введите число")

b = a**2

c = a**3

print("Число во второй степени:",b)

print("Число в третьей степени:", c)

Задание 2

Тут я не понял что подразумевается под словом СЛОЖНЫЕ мат. выражения. В Интернете информация которую я не проходил ещё в школе. Поэтому я программу решающее простые математические выражение. Это самый простой калькулятор на языке Питон 3.

a=int(input("первое число :"))

b=int(input("выберите знак(+\-\*\/):"))

c=int(input("второе число :"))

if b == "+":

d = a+c

elif b == "-":

d = a - c

elif b == "*":

d = a * c

elif b == "/":

d = a / c

else:

print("Вы ввели неверное значение!")

print(d)

Задание 3

i = int(3) #целые числа (integer)

f = float(4.0) #дробные числа (float)

s = school #строковый тип (string)

b = True #логический тип данных (bool)

a = [1,2,3]#список

d = {1:'value', 'key':2} #словарь

print("целые числа (integer): ", i)

print("дробные числа (float): ", f)

print("строковый тип (string): ", s)

print("логический тип данных: True")

print("список: ", a)

print("словарь: ", d)

Надеюсь на все ответил верно :). Если все верно, то отметь как лучший ответ ;)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота