Ксения654654
02.02.2020 11:12

написать программу Нужно написать класс для вычисления площади N произвольных треугольников

N вводит пользователь
Стороны треугольника тоже вводит пользователь

C#
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
daviduk2509
25.07.2021 08:42

var

   n : integer; // длина мвссива

   a : integer; // количество замен

   

begin

   write('введите длину массива ');

   readln(n);

   var d : array of integer := new integer[n]; // создаем массив длиной n

   d := ArrRandom(n, 6, 100); // заполняем массив случайными числами от 6 до 100

   writeln('был сгенерирован массив ', d);

   for var i := 0 to n-1 do begin

       if (d[i] mod 3 = 0) and (d[i] mod 6 <> 0) then begin  // проверяем содержимое ячейки массимассива на условие задачи

           d[i] := 1; // заменяем значение ячейки на 1

           a += 1; // увеличиваем счетчик количества замен на 1

       end;

   end;

   writeln('массив после замены ', d);

   writeln('было произведено замен ', a);

end.


итак...

генерируем массив указанной длины n

заполняем его случайными числами в диапозоне 6..100

так как паскаль нумерует ячейки массива начиная с 0 то задаем цикл от 0 до n-1

проверяем значение ячеек на соответствие условию

для этого делим значение на число и смотрим поделилось без остатка значит кратно ему, поделилось с остатком значит не кратно.

если соответствует условию то меняем значение на 1 и увеличиваем счетчик количества замен на 1

выводим сам массив и количество произведенных замен.

0,0(0 оценок)
Ответ:
wami56
22.08.2020 05:19

10 минут

Объяснение:

Обозначим за  V  — количество данных,  q  — сорость передачи,  t  — время передачи

 

Тогда  V1=V2=12V=12⋅50=25  Мбайт

 

Переведём  25  Мбайт в Кбиты:

 

V1=V2=25Мбайт =25Мбайт⋅8бит=200Мбит=200⋅210 Кбит =50⋅4⋅210 Кбит=50⋅22⋅210 Кбит=50⋅212 Кбит

 

Время передачи определяется как  t=t1+t2=V1q1+V2q2 , где  q1=1024=210  Кбит/с,  q2=10242=512=29  Кбит/с

 

Таким образом,  t=50⋅212210+50⋅21229=50⋅22+50⋅23=50⋅4+50⋅8=200+400=600  c

 

Переведём полученный результат в минуты ( 1  мин  =   60  с):

 

600с:60с=10  мин.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота