singerilt
12.09.2022 06:12

Надо написать код на Visual Basic (6.0). Задача:
Задан массив с количеством элементов N. Сформируйте два массива: в первый включите элементы исходного массива с чётными номерами, а во второй с нечётными. Отсортируйте один из маленьких массивов по убыванию.

В Text1 на форме нужно ввести исходный массив, а в Text2 и Text3 вывести массив только с чётными и нечётными номерами элементов соответственно.
Как можно проще код

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
zaharovdv73
08.05.2022 09:32

===== PascalABC.NET =====

#1

y := (a * x + 2 * b * x * x) * Abs(Cos(x * x)) / (Pi * Exp(x));

y := (a * Ln(b * x)) ** (1 / 3) / (1 + Sqr(Sin(a * x)));

y := (Abs(Sin(x ** 3)) + a) * Exp(a) / (b * b + c * c) ** (1 / 3);

#2

begin

 var (a, x) := ReadReal2('Введите a и x:');

 var t := x ** 3 - a;

 t := Sign(t) * Abs(t) ** (1 / 3);

 var y := t + Sin(x * x) / a;

 Print('y =', y)

end.

Операция возведения в степень ** в PascalABC.NET определена только для неотрицательного аргумента, поскольку она выполняется с использованием логарифма. В то же время, в математике операция извлечения корней нечетной степени для отрицательного аргумента опеределена и допустима. В соответствии с этим, извлечение кубического корня в программе производится из абсолютной величины аргумента и последующим присваиванием знака этого аргумента результату. Если имеется потребность вычислять подобные корни в нескольких местах программы, имеет смысл ввести для этого собственную функцию.


1 переведите формулу на язык паскаль. #2 составить программу вычисления функции у(х); значения перем
0,0(0 оценок)
Ответ:
a18441
08.05.2022 09:32

program z1;

var a: array [1..15] of real;

i, k, b: integer;

proizv: real;

begin

proizv:= 1;

a[1]:= 0.01;

a[2]:= -3;

a[3]:= 0;

a[4]:= 1.25;

a[5]:= -371;

a[6]:= 0.5;

a[7]:= -0.1;

a[8]:= 1.2;

a[9]:= -5;

a[10]:= -172.3;

a[11]:= 19783;

a[12]:= -2.7;

a[13]:= 43.51;

a[14]:= 0;

a[15]:= -0.02;

b:= -3;

k:= 0;

for i:=1 to 15 do

begin

if (a[i] <> 0) and (a[i] > b) then

begin

proizv:= proizv * a[i];

k:= k+1;

end;

end;

writeln('Количество чисел, подходящих условию: ', k);

writeln('Произведение чисел, подходящих условию: ', proizv);

end.

Объяснение:

На фото нарисована блок-схема, она немного криво сфоткана, надеюсь разберёшься. Если есть вопросы - задавай :)


с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота