yeri2
25.08.2020 13:34

Составьте алгоритм (блок-схему) и напишите программу, которая заполняет двумерный массив B размерностью 7х3 по формулам:
в паскале ABC только в нем
очень надо


Составьте алгоритм (блок-схему) и напишите программу, которая заполняет двумерный массив B размернос

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ДанилКопейка
21.06.2020 17:12

96

Объяснение:

Сначала вспомним, что такое конъюнкция: это аналог логической операции И(в простонародье - операции умножения). В бинарной(двоичной) системе счисления она используется так :

0 и 0 = 0

1 и 0 = 0

0 и 1 = 0

1 и 1 = 1

Ну, а теперь возьмём пример

Адрес: 231.32.255.131

Маска: 255.255.240.0

Отлично. Посмотрим сразу на число 255, оно в двоичной системе выглядит так : 11111111. Это значит, что при побитовой конъюнкции любого числа, получается тоже самое число. Т.е. :

231 = 11100111, 255 = 11111111. (возьму первые 4 бита : 1*1=1,1*1=1,1*1=1,1*0=0)

Т.о. 231(логическое И)255=231.

Теперь адрес сети:

231*255=231

32*255=32

255*240=240

131*0=0

Вот и получили адрес сети : 231.32.240.0

Теперь решение задачи :

Тут нужно в обратную сторону. Есть IP адрес, есть узел.

Узел : 98.162.71.123

Адрес: 98.162.71.96

Надо найти правый байт. У узла он равен 123(в десятичной) -> 1111011(в двоичной). У адреса он равен 96(в десятичной) -> 1100000.

Ну, а теперь обратное действие, смотрим на байты узла, умножаем на x, получаем байты адреса. Вот так :

1111011*=1100000

1*х=1 -> x=1

1*x=1 -> x=1

1*x=0 -> x=0

... И так далее, но дальше считать нет смысла, ибо все остальные пять байтов будут равны нулю, т.к. правая часть вся равна нулю(по свойствам выше)

Получили =1100000, а это тоже самое, что и последний байт адреса сети, и равен он 96.

Получили маску : 255.255.255.96

0,0(0 оценок)
Ответ:
Arina8411
05.03.2023 05:45
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var n:=ReadInteger('Количество элементов в массиве: ');
  var a:=ArrRandom(n,-50,50);
  a.Println(',');
  Writeln('Четные элементы: ');
  var i:=1;
  while i<n do begin Write(a[i],' '); Inc(i,2) end;
  Writeln;
  Writeln('Нечетные элементы: ');
  i:=0;
  while i<n-1 do begin Write(a[i],' '); Inc(i,2) end;
  Writeln
end.

Тестовое решение:
Количество элементов в массиве:  10
15,-18,-29,-25,46,21,-8,-17,-9,15
Четные элементы:
-18 -25 21 -17 15
Нечетные элементы:
15 -29 46 -8 -9
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота