Zhanna278
02.03.2020 23:12

Написать программу. Имеется билет на автобус с 6-тизначным номером. Определить, является ли билет счастливым. Нарисовать блок-схему. Язык: Паскаль​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
неудачник16
30.05.2021 14:50

Программа:

var n,a1,a2,s1,s2:integer;

begin

write('n = '); readln(n);

a1:=n div 1000;

s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);

a2:=n mod 1000;

s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);

if s1=s2 then writeln('Билет счастливый')

         else writeln('Билет не счастливый')

end.

Пример:

n = 123231

Билет счастливый

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота