alexgreen5454
25.01.2023 23:55

Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяет его на значение произведения элементов
(остальных) массива (второй массив не использовать). Программа выводит
исходные данные и измененный массив.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastyakulikova5
27.06.2021 13:05

Объяснение:

Python

from random import randint

n=int(input('Введите размер матрицы  :'))

a=[randint(1,20) for j in range(n)]

print(a)

m=max(a)

ind = a.index(m)

print('Максимальный элемент a[',ind,']=', m)

p=1

for i in range(n):

  if i!=ind:

     p*=a[i]

a[ind]=p

print(a)


Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяе
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота