Мария1111121
03.09.2021 11:03

Написать программу на pascal, которая определяет, существует ли треугольник со сторонами a,b,c,зная, что сумма двух сторон треугольника всегда больше третьей

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
doc2510
23.06.2020 16:16

program raf105;

var

 a,b,c: integer;

 x: boolean;

begin

 x:= True;

 write('Введите 3 числа через пробел: ');

 readln(a,b,c);

 if a+b < c

   then x:= False;

 if a+c < b

   then x:= False;

 if b+c < a

   then x:= False;

 if x

   then writeln('Треугольник существует')

   else writeln('Треугольника не существует');

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота