Бодичка539
06.03.2021 21:21

Программная форма записи алгоритма «собрать рюкзак в школу» или «выполнить » не словесная! начинается с program

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
UGvu
25.08.2022 03:56

#include <array>

#include <iostream>

#include <algorithm>

#include <numeric>

#include <iterator>

int main()

{

   std::array<int, 5> arr;

   std::generate(arr.begin(), arr.end(), []()

   {

       return 1 + std::rand() % 100;

   });

   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator<int>(std::cout, " "));


   std::cout << std::endl << std::accumulate(arr.begin(), arr.end()-3, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-2, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end()-1, 0) << std::endl;

   std::cout << std::accumulate(arr.begin(), arr.end(), 0) << std::endl;

}


C++ напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых
0,0(0 оценок)
Ответ:
mashkavoronina
08.09.2022 06:48

Задача 1

(I - информационный объем текста, K - кол-во символов, i - вес одного символа/бит на символ)

Дано:

K = 290 * 39 * 67 = 757770 шт

Пусть i = 8 бит (Кодировка ASCII)

I - ?

I = K * i = 757770 * 8 бит = 6062160.0 бит

6062160.0 бит = 757770.0 байт = 740.009765625 Кбайт = 0.7226657867431641 Мбайт < 1.44 Мбайт  значит  можно

ответ да


(I - информационный объем текста, K - кол-во символов, i - вес одного символа/бит на символ)

Дано:

K = 256 * 95 * 80 = 1945600 шт

Пусть i = 8 бит (Кодировка ASCII)

I - ?

I = K * i = 1945600 * 8 бит = 15564800.0 бит

15564800.0 бит = 1945600.0 байт = 1900.0 Кбайт = 1.85546875 Мбайт = 0.001811981201171875 Гбайт

2 - 0.001811981201171875 = 1.998188019 Гбайт

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота