Yerkosyaorynbekova
30.04.2023 11:21

Составить программу- игру на паскале. "меткий стрелок". случайным образом задаём координаты точки и определяем, попала точка в цель или нет. цель - окружность с центром в начале координат, радиусом 5. в нужно использовать ветвление и уравнение окружности. результатом будет сообщение : "стрелок попал в цель" или " не попал."

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Дарья02031
27.04.2022 11:19
Преимущества командного интерфейса

Очень низкие требования к аппаратным средствам — минимально для работы требуется клавиатура и символьное устройство вывода или терминал, соединённый с машиной.

Высокая степень унификации — всё взаимодействие обеспечивается через две функции: ввод и вывод символов, часто реализуемые через файловый ввод-вывод.

Широкая возможность интеграции программ — посредством использования командного интерпретатора и перенаправления ввода-вывода.

Недостатки командного интерфейса

Плохая наглядность интерфейса — необходимо помнить команды или пользоваться справочником.

Ограниченные возможности вывода информации — отсутствие графики
0,0(0 оценок)
Ответ:
nastiadair
18.03.2021 13:55
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
// Внимание! В более ранних версиях программа работать не будет!
begin
  var d:=MatrRandom(4,4,-20,20);
  Writeln('Исходный массив'); d.Println(4);
  var s:=d[0,0];
  for var i:=1 to 3 do begin d[i,i]:=d[i,0]; s+=d[i,i] end;
  Writeln('Полученный массив'); d.Println(4);
  Writeln('Сумма на главной диагонали ',s)
end.

Пример
Исходный массив
  14   8 -12  12
  15  -9 -16  -6
  18  -7   7   5
  -7 -12 -10 -14
Полученный массив
  14   8 -12  12
  15  15 -16  -6
  18  -7  18   5
  -7 -12 -10  -7
Сумма на главной диагонали 40
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота