Alexandraananeva
22.12.2021 21:11

Написать программу в паскале составить программу которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный массив

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
moki2
21.06.2020 12:06
Var a: array [0..10, 0..50] of integer;
    b: array [0..10] of integer;
    i, j: integer;
begin
     for i := 0 to 10 do
     begin
         for j := 0 to 50 do
         begin
              a[i, j] := random(50);
              write(a[i, j]:3);
         end;
         writeln();
     end;
                       for i := 0 to 10 do
         for j := 0 to 50 do
             b[i] := b[i] + a[i, j];
                  for i := 0 to 10 do
             write(b[i], ' ');
end.

Можно было, конечно, поменьше циклов, но так нагляднее будет =)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота