Batman781
09.06.2023 03:34

Написать программу которая будет вводить на экран максимальный элемент любого целочисленного массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
просто346
01.10.2020 11:21
Если паскаль, то - 

const n:=100; //в массиве пусть будет 100 элементов
var tarray:array[1..n] of integer;
max:integer;
i:=byte;
begin
{тут заполнение массива}
max:=tarray[1]; //думаем что максимум - это первый элемент
for i:=1 to n do 
 if max > tarray[i]
  then max:=tarray[i];//если встречаем элемент больше максимального - то он -новый максимальный 
write('Максимальный элемент - ', max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота