Makcuм
23.04.2021 16:44

Программа python 3.0 и 1) Укажите грубую ошибку в коде теоретического характера
model = XGBClassifier(max_depth = 4, n_estimators = 20000)
model.fit(x_train, y_train)
y_pred = model.predict(x_test)

2)Укажите грубую ошибку в следующем коде
from sklearn.preprocessing import LabelEncoder
l_encoder = LabelEncoder()
l_encoder.fit(df_test)
df_test = l_encoder.transform(df_test)
l_encoder.fit(df_train)
df_train = l_encoder.transform(df_train)

3) Укажите грубую ошибку в следующем коде
from sklearn.preprocessing import MinMaxScaler
scaler = MinMaxScaler()
scaler.fit(df_train['rating'])
df_train['rating'] = scaler.transform(df_train['rating')
scaler.fit(df_test['rating'])
df_test['rating'] = scaler.transform(df_test['rating')

4) Укажите грубую ошибку в следующем коде
from sklearn.preprocessing import OneHotEncoder
hot_enc = OneHotEncoder()
hot_enc.fit(df_train['rating'])
one_hots = hot_enc.transform(df_train['rating'])
24
one_hots = pd.DataFrame(one_hots)
df_train = pd.concat([df_train, one_hots], axis=1)
df_train.drop(['rating'], axis=1, inplace=True)
hot_enc.fit(df_test['rating'])
one_hots = hot_enc.transform(df_test['rating'])
one_hots = pd.DataFrame(one_hots)
df_test = pd.concat([df_test, one_hots], axis=1)
df_test.drop(['rating'], axis=1, inplace=True)

5) Исправьте код — нужно ускорить работу программу
for i in range(len(f)):
if np.isnan(f[i]):
f[i] = 2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
АнальныйЧервь
09.10.2020 12:44

Объяснение:

Схе́ма Го́рнера (или правило Горнера, метод Горнера, метод Руффини-Горнера) — алгоритм вычисления значения многочлена, записанного в виде суммы мономов (одночленов), при заданном значении переменной. Метод Горнера позволяет найти корни многочлена[1], а также вычислить производные полинома в заданной точке. Схема Горнера также является простым алгоритмом для деления многочлена на бином вида {\displaystyle x-c}x-c. Метод назван в честь Уильяма Джорджа Горнера, однако Паоло Руффини опередил Горнера на 15 лет, а китайцам этот был известен еще в XIII веке.

0,0(0 оценок)
Ответ:
MrsKamYl
29.09.2020 16:16
Var St: string;
 z:string[10];
 x:string[2];
i,j,k,m: integer;           //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0;                       //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
 begin;
  for m:=1 to 10 do
   if St[j]=z[m] then inc(k);
 end;
if k=0 then
begin;
 writeln('в тексте нет цифр');
 exit;
end;                              //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота