Аляяяя0604
21.04.2022 03:23

Написать программу которая находит: 1) в последовательности натуральных чисел сумму всех чисел, которые кратны 4 и заканчиваются на цифру 2, кол-во чисел вводит пользователь 2) последовательность заканчивается 0 3)найти кол-во чисел, которые не больше 100 4) подсчитать сумму всей последовательности паскаль abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Титанэжжжжж
29.08.2020 01:33
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
0,0(0 оценок)
Ответ:
CLS
a:
INPUT n
IF n < 1 OR INT(n) <> n OR n > 1000 THEN GOTO a
DIM a(n)
h=30000
FOR i = 1 TO n
b:
INPUT a(n)
IF a(n) < 1 OR INT(a(n)) <> a(n) OR a(n) > 30000 THEN GOTO b
IF INT ((a(n) - 4 ) / 10) = ((a(n) - 4) / 10) AND a(n) < h THEN h = a(n)
NEXT i
PRINT h
END
или:
n - количество чисел
i - цикловая переменная
a  - натурально число
min  - минимальное число, оканчивающееся на 4
Язык програмирования: Паскаль
var
n,i,a,min: integer;
begin
readln(n);
min := 30001;
for i := 1 to n do
begin
readln(a);
if (a mod 10 = 4) and (a < min) then
min := a;
end;
writeln(min)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота