Войти
Регистрация
Спроси ai-bota
sofa4565787
07.01.2020 19:42
Необходимо записать уравнения P и С на языке программирования VBA
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
niknik14
07.06.2023 05:13
Тест по теме Работа с таблицами в MS Word 1)Упорядоченная в строках и столбцах информация называется: a) ячейка;B б)таблица;B в)списокB гтекст 2)как называется место, находящиеся...
Vilhctein1989
13.10.2021 15:52
по информатике, заранее благодарю...
mrpixkaGogar
31.03.2021 00:49
Напиши запрос (база данных MS Access): записи, в которых названия стран заканчиваются на ак ....
natalia04062001
10.10.2020 21:07
ИНФОРМАТИКА ПЯТЫЙ КЛАСС задание 2 ( ).Используя диалоговое окно «Абзац», установите отступ абзаца 1.25.Задание 3 ( ).Разместите данные об авторе текстового фрагмента и...
Котик2525
12.11.2021 11:58
изучив физическую карту мира выберите верные утверждения характезирищующие положение материка Австралия...
FROST22223333
12.11.2021 11:58
Как называется совокупность всех программ на компьютере ?...
Рина201
29.09.2020 22:10
Каждый пользователь некой компьютерной системы получает уникальный идентификатор,представляющий собой k-символьную цепочку в четырехбуквенном алфавите.Укажите наименьшее...
диана2376
15.01.2020 23:13
Python Вам даны круг и треугольник на координатной плоскости. Определите, лежит ли треугольник целиком внутри круга. Формат входных данных В первой строке вводятся через...
артем1488337
28.04.2021 03:03
Как будет выглядеть данная программа в переводе с паскаля на с++ var A: Integer; var x, zp :real; label m; begin writeln( введите зарплату ); readln(x); m: writeln ( введите...
Даниэлла25111
06.11.2021 19:41
ASKII артықшылығы мен кемшілігі...
Ответ:
marisa10
26.11.2021 09:33
[l,r,строка,номер]
[0, 0, "a", 1]
[1, 1, "b", 2]
[1, 2, "bb", 3]
[2, 2, "b", 4]
[0, 3, "abba", 5]
[3, 3, "a", 6]
[3, 4, "aa", 7]
[4, 4, "a", 8]
[3, 5, "aaa", 9]
[4, 5, "aa", 10]
[5, 5, "a", 11]
[3, 6, "", 12]
[4, 6, "aaa", 13]
[5, 6, "aa", 14]
[6, 6, "a", 15]
[2, 7, "bb", 16]
[7, 7, "b", 17]
[6, 8, "aba", 18]
[8, 8, "a", 19]
[7, 9, "bab", 20]
[9, 9, "b", 21]
#код программы Ruby 22
s = "abbbab"
n = 0
for r in 0..s.size-1
for l in 0..r
t = s[l..r]
if t.reverse == t
n += 1
p [l,r,t,n]
end
end
end
0,0
(0 оценок)
Ответ:
vlada363
16.03.2020 21:38
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота