паскаль ))составить программу, которая по дню выводит время приёма врача Дни недели Часы приёма Понедельник, вторник 8.30-14.30 Среда, четверг 13.00-19.00 Пятница 11.30-17.30 суббота 9.30-13.30 воскресенье Приёма нет
Var mas:array[1..1000, 1..1000] of integer; N,M,i,j,k:integer;
Begin Writeln('Введите размер матрицы N*M'); Write('N = '); readln(N); Write('M = '); readln(M);
if (M>1000) or (N>1000) or (M<1) or (N<1) then Writeln('Ошибка, указанные значения выходят за пределы матрицы') else Begin Writeln('Введите элементы матрицы');
k:=0; for i:=1 to N do for j:=1 to M do Begin readln(mas[i,j]); if (mas[i,j] mod 2 = 0) then k:=k+1; end;
Writeln(); Writeln('Исходная матрица');
for i:=1 to N do Begin for j:=1 to M do Begin Write(mas[i,j], ' ') end; Writeln(); end;
Writeln(); Writeln('Количество четных элементов = ',k); end;
1) F=Av(¬A&B) По закону дистрибутивности раскроем скобки (Av¬A)&(AvB) Av¬A = 1, значит остаётся AvB
2) F =A&(¬AvB) По тому же закону раскрываем скобки (A&¬A)v(A&B) A&¬A = 0, значит остаётся A&B
3. (AvB)&(¬BvA)&(¬CvB) По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид A&(¬CvB) Можно раскрыть скобки, получим A&¬C v A&B
4) F =(1v(AvB))v((AC)&1) Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1 Получаем выражение 1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1 ответ 1
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку