kiss01522
10.09.2022 06:15

Составить программу, находящую сумму всех чисел от 1 до 50. Составить программу, находящую сумму чётных чисел от 111 до 200.
Даны три числа:a,b,c. Удвоить каждое из данных чисел, если c<или=b, b<или=a и заменить числа их модулями в противном случае.
Даны два числа:a,b. Вывести на печать первое, если оно>второго и оба числа, если это не так. ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vikysik927
10.06.2021 16:10

Язык: Java

1.

public class Sum {

public static void main(String args[]) {

//n — первая граница чисел, sum — сумма чисел; i — складыватель числа n — на саму себя

int n = 0, sum, i = 0;

//i — стремится к 50, каждый раз увеличиваясь на 1 — но одновременно давая своё значение переменной n.

for(; i <= 50; i++) {

n += i;

}

System.out.println(n);

}  

}

Output: 1275.

2.

public class Sum1 {

public static void main(String args[]) {

//Одни и те же переменные, но только i — должен быть на 2 больше n, так как в цикле for — подчёт начинается сразу с заранее заданным значением.

int n = 112, sum, i = 114;

//Кстати заметили, что n — начинается не с 111? Потому что в цикле, подчёт, и складывание на 2 — начнётся именно с 111, и в итоге все цифры будут нечётными, поэтому первая цифра должна быть чётной, и больше 111, то есть — 112.

for(; i <= 200; i+=2) {

n += i;

}

System.out.println(n);

}

}

Output: 7020.

3.

Ты имеешь ввиду — вывести в противоном случае все числа — в модулях? Или поменять их знаки, с отрицательного на положительного, и наоборот?

//Создание класса Scanner, для последующих вводов пользователя

import java.util.Scanner;

public class Sum {

   

   public static void main(String args[]) {

int a, b, c;

//Для возможности ввода пользователя, создадим объект "input" класса Scanner

Scanner input = new Scanner(System.in);

//Ввод пользователя

System.out.println("Enter the first number: ");

a = input.nextInt();

System.out.println("\n Enter the second number: ");

b = input.nextInt();

System.out.println("\n Enter the third number: ");

c = input.nextInt();

//Условия, заданные в задаче. Знак "&&" означает "также"

if(c<=b && b<=a) {

    a = a*2;

    b = b*2;

    c = c*2;

}

//Math.abs() — метод, который возвращает абсолютное значение числа, то есть выводит в модуль.

else {

   System.out.println("\nThe first number: " + Math.abs(a) + "\nThe second number: " + Math.abs(b) + "\nThe third number: " + Math.abs(c));

}

      }  

   }

4.

import java.util.Scanner;

public class Sum {

   public static void main(String args[]) {

//Объявленя двух чисел

int a, b;

Scanner input = new Scanner(System.in);

//Ввод пользователя

System.out.println("The first nubmer: ");

a = input.nextInt();

System.out.println("\nThe second number: ");

b = input.nextInt();

if(a>b) {

    System.out.println("\n" + a);

}

else {

    System.out.println("\n" + a + "; " + b);

}

      }

       

   }

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота